2012
01.28

I recently moved my Mini-Itx Rig from Windows to Linux and had picked Fedora 16 as the Distro.

After a few hours of using Gnome3 I decided to ditch it and switch to KDE (Seriously what are the gnome dev’s smoking, it’s horrible to work with)

So I installed KDE and set about setting it up with my Dual monitors.  I’d gotten everything setup just how I wanted it and decided to call it a day, so I shut the machine down

On the next boot-up I found that KDE had promptly decided to forget my monitor configuration and instead revert to cloning the primary display, it had also forgotten that the secondary Display is infact on the Left in my setup.

After some Goggling I found this page which helpfully tells you how to create a script to reapply your xrandr settings on login seeing as saving the settings (even using the save as defaults option) on Xrandr appears not to work.

Whilst this sorted the original problem it quite annoyingly seems to cause me to run into Bug #260360 which is very much not resolved despite the bug-tracker suggesting otherwise.  Whilst my desktop Background is very nice and all it would be much more useful to actually see my windows/panels…

 

Looking into the workarounds posted, I wasn’t really happy with most of them switching activities may fix the problem but it’s a pain in the backside to say the least.  One workaround around that seems to work for me is to slay and then restart plasma-desktop after configuring my screens.

I use the following commands to do this, you could use kquitapp instead of killall but I find doing so seems to make the automatic bug reporter launch more often than not.

killall plasma-desktop

plasma-desktop &

Now Naturally I don’t really want to be trying to bring up a console when I’m experiencing the issue with the desktop, so I added the commands to the end of the script I’d created earlier to setup the monitors during start-up

The entire script I use to setup the screen resolutions/locations for my monitors and restart the desktop now looks like this

xrandr –output HDMI-0 –pos 1920×0 –mode 1440×900 –refresh 59.8874
xrandr –output DVI-0 –pos 0x0 –mode 1920×1080 –refresh 60
xrandr –output HDMI-0 –primary
killall plasma-desktop
sleep 2
plasma-desktop &

 

Note:do Not blindly copy the above as the xrandr settings are specific to my monitor setup the part of the script that kills/restarts plasma is

killall plasma-desktop
sleep 2
plasma-desktop &

It’s a bodge and I’m pretty sure there must be a better way to go about getting dual screens working properly but in the meantime at least now I actually get a desktop that is usable and makes use of both monitors when I login.

2012
01.01

Happy New Year!

Happy New Year Everyone.